August 28, 2020
Installing the ColdFusion 2020 Public Beta Through the Eyes of Someone New
Comments
(0)
August 28, 2020
Installing the ColdFusion 2020 Public Beta Through the Eyes of Someone New
Wizard 36 posts
Followers: 20 people
(0)

ColdFusion 2020 has reached the public beta phase.  It’s time to play with some of the new ColdFusion hotness that’s coming in the near future.  I had a few problems when I went through the process of setting up the new CF 2020, but I recognized that there were a couple of places where people could get tripped up as well.  Some of these issues I fell for… some of them I made up to point out flaws in the process.

I’ve started with a virtual machine with a fresh install of Windows Server 2019 with IIS 10 installed.  So far so good.  I made sure IIS had the standard prerequisites installed… .net, CGI, ISAPI, etc.

My next step is to go to adobeprerelease.com and download the ColdFusion 2020 Public Beta installers.  This is simple and straightforward.  Once I logged in, I saw the “Project Stratus Public Beta” link, visited the page and downloaded the Project Stratus Beta Win 64 Bit Installer file.

Once the download is complete and I extracted the contents, I saw a “ColdFusion” folder.  “Okay,” I think, “this must be where the installer is.”  I went into the folder and saw folders for “cfusion”, “jre”, “config”, etc… it looked like the file structure of ColdFusion as it exists after it’s been installed.

“Huh,” I thought.  “Where’s the setup.exe file?”  I remembered in some of the presentations that Rakshith gave about the upcoming changes in CF 2020 that the install experience would be different, but I didn’t know what to do here.  Maybe there were some instructions on the beta download page?  I’m confused.

I went back to the Adobe Prerelease download page and read the text above the downloads… there was nothing related to installs.

“Maybe it’s in the forums?” I asked myself.  I clicked on “View All Forums” and, a-ha!  “Documentation” on the left column… with nothing in it.  Okay.  Another dead end.  Maybe it was in the “Welcome to the public beta of Project Stratus” article?  Nope.  What the hell… I’ve downloaded it… how do I install this thing?  I’m not that dumb, am I?  Certainly there’s some release notes here somewhere…

And then I found it.  Back on the installers downloads page, near the bottom, is a link to “Project Stratus Beta Release Notes.”  A 508-page PDF file that includes, you guessed it… installer instructions.

Note to Adobe:  Create a “Quick Start” and post it on the page for idiots such as myself to quickly find and get started.  At the very least, big, bold, red letters that read “Installation instructions are available in the release notes.”

The instructions are pretty simple.

  1. “Unzip the ProjectStratus_Beta.zip file.”  Easy peasy.  Done.
  2. “Navigate to ColdFusion/cfusion/bin.”  Okay.  I double click the folders to navigate to the right one.
  3. “Enter cfinstall.bat and follow the on-screen instructions.”  Waitaminute… enter?  Double-click?  Was I supposed to be doing this in a command prompt?  They must mean double-click or execute the file. Otherwise they would say to enter “.cfinstall.bat”, right?

This brought up the first issue… the scary Windows Defender “we’re not going to let you run this unless you agree that you know what you’re doing” screen, as seen in the screenshot below.

I click on the “more info” link and the “Run anyway” button and up comes a command prompt with what I recognized as the ColdFusion installer.  This looks a lot like the command line installer I’ve run many times when installing ColdFusion on an Ubuntu installation… so it was weird to see this experience in a Windows environment rather than the standard “Install Anywhere” installer I’m used to.

Regardless.  There’s a Welcome to Project Stratus Setup Wizard… let’s run through it.

  • Do I accept the terms of the license agreement?  Sure.  Why not.
  • Enter an Administrator password, and repeat it.  No problem.
  • Project Stratus Administrator Port?  I hit enter to leave it the default port 8500.
  • I set an RDS password and confirmed it.
  • The next step was new to me.  “Service Name for Project Stratus Application Server?”  Interesting… but I press enter to leave it the default.
  • Type of deployment?  I press enter to leave it the default setting of “Developer” but I like what I’m seeing here; options for Production, Developer, Staging, Testing, and Disaster Recovery.
  • Do you want to continue with the install?  Well… I didn’t come all this way for nothing.

Once I commit, I noticed the terminal prompt a quick message saying “installing service” and then closed entirely. I can’t help but think that if I ran this from the command prompt instead of double clicking the file, it would have stuck around.

But waitaminute… there’s no way it installed it that quickly… And I don’t see the typical C:ColdFusion directory (Or in this case CrojectStratus_Beta?)  So did it install it in place?  Was I supposed to move that extracted folder out of my downloads folder before performing the installation?  Is ColdFusion now running?  It’s time to run some tests.

Before I do anything, let’s see if ColdFusion is running.  I open up a browser and point it to http://127.0.0.1:8500 and I see a familiar sight!

Okay… this is good.  ColdFusion is running.  I enter the administrator password to complete the setup and then try another test.

Next I create a simple index.cfm in the C:inetpubwwwroot folder with a single line in it.

<cfoutput>#dateFormat(now())#</cfoutput>

This should tell me is ColdFusion is running on the IIS website.  Installing CF 2018 on an Ubuntu machine required running the web server connector separately, and I didn’t see anything in the installer that was indicating that the web server connector installed… so I don’t think this is going to work.  Sure enough… I get the screenshot below.

No problem here… I know I need to run the wsconfig.exe to install the web server connectors.  I open PowerShell and type in:

cd C:UsersAdministratorDownloadsColdFusioncfudionruntimebin
.wsconfig.exe

…and that’s when the wheel really fell off the wagon.  Here’s what I saw:

…so I was clearly missing something.  And this is where I got stuck.  I’ll write another article with my next steps once I get over this hurdle, but so far the experience has met some hindrances.

More to come…

0 Comments
Add Comment