Updating ColdFusion 9 For TLS 1.2 Usage

July 29, 2019
Newbie 1 posts
Followers: 0 people
4

Updating ColdFusion 9 For TLS 1.2 Usage

Newbie 1 posts
Followers: 0 people
July 29, 2019

We are using ColdFusion 9.0.1 with jdk 1.7.0_75 version. We have to use TLS 1.2 in our systems.

We have tried:

  • Added -Dhttps.protocols=TLSv1.2 line to JRun4 > bin > jmv.config file.
  • Installed jdk1.8.0_172 – jdk1.8.0_221 versions and changed JRun4 > bin > jmv.config > java.home path. After that when i want to open web page, opens empty page. It is empty between body tags. There is no error. I have read an article linked below, i can use ColdFusion 9 with Java 8 without problem.

Here is the Stackoverflow link:

https://stackoverflow.com/questions/50767125/server-and-jre-are-set-to-tls-1-2-but-coldfusion-9-still-trying-to-use-tls-1-0?noredirect=1&lq=1

Infact, question is simple.

How can we use ColdFusion 9 with TLS 1.2?

My OS Windows 2008 Server R2, running on Vmware and JRE 8 installed already.

Thanks for you replies.

Comments (4)
2019-07-30 15:47:09
2019-07-30 15:47:09

Thank you for your clarification Charlie, probably I summarized a little too much.

The sense of my response was based on the assumption that nobody should install a JVM in production that is not officially supported by Adobe, because maybe it all works, but if not… my customers doesn’t deserve such type of patchwork

By the way, thank you for your insightful and extremely enlighting posts!

Like
(1)
>
gabrieleb5037809
's comment
2019-07-30 16:01:01
2019-07-30 16:01:01
>
gabrieleb5037809
's comment

Thanks for the kind regards, and indeed you are right and wise to warn people about running unsupported configurations. I try to do so as well, whenever I may mention it, but I realize that some people are determined to “solve their one problem” even at risk of causing others. As the saying goes, “you can lead a horse to water, but you can’t make him drink.” 🙂

Like
(1)
2019-07-30 15:31:13
2019-07-30 15:31:13

It’s not quite that you CANNOT use Java 8 with CF9, Gabrieleb, but rather that it was never supported by Adobe. Some folks HAVE updated CF9 (or earlier) to use Java 8, and it worked for them (solved this problem), while other have indeed had problems.

Also, there could be still other explanations for Hakan’s problems. Hakan had also asked this question yesterday in a blog post of mine (and because of an unrelated technical problem I couldn’t get my reply posted until this morning). Here is what I said there, in case it may help others finding this discussion here on the CF portal:

First, it’s worth nothing that CF9 was never updated to run Java 8. Still, many have run the two, to solve such problems and it worked (some have had problems, but they could have other explanations, since changing the JVM CF uses is indeed touchy business).

Indeed, as for the blank pages, it could be that something has gone amiss in your attempt to update the jvm and its args–assuming that is indeed all you did. I have a post on several common problems doing that, and how to solve them:

http://www.carehart.org/blog/client/index.cfm/2014/12/11/help_I_updated_CFs_JVM_and_it_wont_start

Third, yes it’s likely that the change needed to solve your tls problem was indeed the need to update the jvm. I discuss this more here:

https://coldfusion.adobe.com/2019/06/error-calling-cf-via-https-solved-updating-jvm/

Or, if you just want the problem solved, I can help remotely and often quickly via my consulting. See https://www.carehart.org/consulting.

Sorry that the last comment may seem sales-y. Again, I am quoting what I wrote on my blog. I could have just offered a link to the comment, but I thought the other two points and links worth making sure people here saw them, even if they may not be tempted to follow a link to more.

Like
(1)
2019-07-30 12:47:07
2019-07-30 12:47:07

Simply said, you can’t use any JDK > 1.7 with CF9. So no JDK 1.8 with TLS1.2 support.

https://coldfusion.adobe.com/2014/11/which-jdk-is-supported-with-coldfusion-9-10-and-11/

At your risk, there is a workaround involving some 3rd party components:
https://coldfusion.adobe.com/2018/02/tls-1-2-for-coldfusion-9-and-older/

Like
Add your comment