Another instance of wsconfig appears to be running

July 17, 2019
Newbie 1 posts
Followers: 0 people
1

Another instance of wsconfig appears to be running

Newbie 1 posts
Followers: 0 people
July 17, 2019

How do I resolve the issue that seems to have been created during the addition of a new site? I selected the site for “update” and I continue to receive the error “Another istance of wsconfig appears to be running”. I can’t access the wsconfig.exe (Web Server Configuration Tool) at all.

Comments (1)
2019-07-22 17:38:04
2019-07-22 17:38:04

I’m pretty sure it means what it says. 🙂 But I gather you feel confident that you don’t have another one running, right? Well, let’s confirm what we can.

1) So first, check Task Manager (since you say wsconfig.exe, that tells us you’re on Windows. Readers on Linux would use top or the equivalent.) Go to the Details tab, and see if there is any java.exe listed. If so, that could be an instance of this. (BTW, it will indeed show as java.exe, not wsconfig.exe. The latter launches the former. That may be why you thought there was “no other running”.)

If you’re on a recent Windows version, which shows both processes and details tabs in Task Manager, the one in Processes may indicate “java platform se binary”, but note that you should be able to click it to expand it. If it shows “web server configuration”, then that’s one running. Are there more than one?

On older versions of Windows (or in that Details tab on modern ones), you could right-click it and choose properties, to at least see if the java.exe is one running in the JRE folder of the JVM that CF is pointing to (showing in the CF Admin Java and JVM page.)

If there are more than one, then in order to see if each is running the wsconfig, you’d need to tell Task Manager to also show the “command line” for each process. That’s nifty but beyond the scope of this reply to answer. But if you did and the argument to java.exe there references the ConnectorInstaller, that is indeed the wsconfig running.

2) Finally, if you would say “nope, it’s still not there”, I will point out that it could be some other user logged into the box. If you look at the “users” tab in task manager, does it show any other users?

If it does, but you still “don’t see another listed” then you may not be able to see THEIR running tasks, if you are not an admin (or have not told Task Manager to “show all processes”) then you may not see them.

Let us know how it turns out, Jason.

Like
Add your comment