Amazon Corretto Support/ Java Going away

December 4, 2018
Newbie 1 posts
Followers: 0 people
6

Amazon Corretto Support/ Java Going away

Newbie 1 posts
Followers: 0 people
December 4, 2018

We are running CF10 and CF2016 on jre1.8.0_191, however after the first of the year it appears that Java won’t be available with paying for it. 

Is there a plan to either get CF on Java 11 or get users the new patches? 

I have also experimented with Corretto on CF10 and CF2016 and that looks promising, is there going to be support for Corretto?

Comments (6)
2018-12-07 23:29:28
2018-12-07 23:29:28

To rcasdorph, yes. Adobe is aware of the issue, and has begun addressing it (more in a moment).

First, though, it’s not that you won’t be able to use Java 8 without paying for it: it’s that you are not going to be able to get *updates* to it for free, if you use it for commercial purposes. (Still bad news for most of us, but different than what you said.)

Second, the news is ever worse for Java 11: we won’t be able to use it for free for ANY production use at all (not just “commercial”). And even Oracle’s free openjdk implementation of Java 11 (which we could use for commercial/production use if and when CF supported it), Oracle  has stated that they will update it only for 6 months, then leaving it to the community after that.

The confusion and concern on all this is understandable. And for those interested, these are issues I have clarified further in a blog post I did a couple of weeks ago:

https://www.carehart.org/blog/client/index.cfm/2018/11/15/on_CF_and_commercial_use_of_java_going_forward

Then as for Coretto (Amazon’s openjdk implementation, which WILL have a much longer support timeframe), I I did a post on that also right after the other: https://www.carehart.org/blog/client/index.cfm/2018/11/15/considering_amazon_corretto_open_jdk.  FWIW, I reported there that CF 2016 did at least “work” (and I explain why it can’t work for now for CF2018), though I clarify also how–as you ask here–we need to hear officially from Adobe on whether they will support it.

And as for Java 11, Adobe did say in another comment in a post here ( https://coldfusion.adobe.com/discussion/2514693/) that they do plan to update CF2018 and 2016 to support Java 11, in an update planned for Jan/Feb. (No mention there as of yet about CF11 or about support of openjdk implementations.)

As for further questions/complaints/concerns on all this, they really should be voiced on the blog post Adobe posted on the matter: https://coldfusion.adobe.com/2018/10/oracles-java-policy-change/, rather than in more and more scattered forum posts and portal questions.

Finally, FWIW, my previous comment was meant as a reply to James (asking about whether Adobe posted what versions of CF supported what versions of Java), but I meant to click “reply” but forgot, so it ended up as a new comment. Sorry if that will seem out of context to some readers.

Like
2018-12-07 23:07:10
2018-12-07 23:07:10

They have over time, such as here:

https://coldfusion.adobe.com/2014/11/which-jdk-is-supported-with-coldfusion-9-10-and-11/

But it does need updating for CF2016 and 2018. I can tell you that CF2016 came out on Java 8 and for now supports only that, while CF2018 came out on Java 10 (and for now supports only that). But Adobe has said in comments elsewhere that both 2016 and 2018 will be updated to support Java 11. (No word on whether CF11 will, though technically its public support doesn’t end until April 2019.)

Like
2018-12-06 20:16:14
2018-12-06 20:16:14

I wish it was documented by Adobe the versions of Java that ship with each version ColdFusion

And the supported versions of Java for a given version of ColdFusion.

Like
2018-12-06 15:59:27
2018-12-06 15:59:27

I’m in the same boat, running on CF2016. We will be switching over to Corretto by the end of the month. As of right now, Corretto is an Amazon project and they will be supporting it.

Like
(2)
>
CavanVannice
's comment
2018-12-10 17:51:24
2018-12-10 17:51:24
>
CavanVannice
's comment

Which they are you referring to?

Adobe they or Amazon they?

Like
>
James Mohler
's comment
2018-12-10 17:53:33
2018-12-10 17:53:33
>
James Mohler
's comment

James, I know you’re asking Cavan, and I had the same question at first when I saw the comment, but I think the point he or she is making was about how Amazon will be supporting Coretto for such a long time.But neither of you (nor the OP, rcasdorph) have responded to my other comments here on all this stuff. Any thoughts? Has it helped?

Like
Add your comment